summaryrefslogtreecommitdiffstats
path: root/svtools/CppunitTest_svtools_html.mk
diff options
context:
space:
mode:
Diffstat (limited to 'svtools/CppunitTest_svtools_html.mk')
-rw-r--r--svtools/CppunitTest_svtools_html.mk30
1 files changed, 30 insertions, 0 deletions
diff --git a/svtools/CppunitTest_svtools_html.mk b/svtools/CppunitTest_svtools_html.mk
new file mode 100644
index 000000000..6fbca2c06
--- /dev/null
+++ b/svtools/CppunitTest_svtools_html.mk
@@ -0,0 +1,30 @@
+# -*- Mode: makefile-gmake; tab-width: 4; indent-tabs-mode: t -*-
+#
+# This file is part of the LibreOffice project.
+#
+# This Source Code Form is subject to the terms of the Mozilla Public
+# License, v. 2.0. If a copy of the MPL was not distributed with this
+# file, You can obtain one at http://mozilla.org/MPL/2.0/.
+#
+
+$(eval $(call gb_CppunitTest_CppunitTest,svtools_html))
+
+$(eval $(call gb_CppunitTest_use_external,svtools_html,boost_headers))
+
+$(eval $(call gb_CppunitTest_use_sdk_api,svtools_html))
+
+$(eval $(call gb_CppunitTest_add_exception_objects,svtools_html, \
+ svtools/qa/unit/testHtmlReader \
+ svtools/qa/unit/testHtmlWriter \
+))
+
+$(eval $(call gb_CppunitTest_use_libraries,svtools_html, \
+ comphelper \
+ cppu \
+ cppuhelper \
+ tl \
+ sal \
+ svt \
+))
+
+# vim: set noet sw=4 ts=4: