summaryrefslogtreecommitdiffstats
path: root/test/Module_test.mk
diff options
context:
space:
mode:
Diffstat (limited to 'test/Module_test.mk')
-rw-r--r--test/Module_test.mk28
1 files changed, 28 insertions, 0 deletions
diff --git a/test/Module_test.mk b/test/Module_test.mk
new file mode 100644
index 000000000..080cc855b
--- /dev/null
+++ b/test/Module_test.mk
@@ -0,0 +1,28 @@
+# -*- Mode: makefile-gmake; tab-width: 4; indent-tabs-mode: t -*-
+#
+# This file is part of the LibreOffice project.
+#
+# This Source Code Form is subject to the terms of the Mozilla Public
+# License, v. 2.0. If a copy of the MPL was not distributed with this
+# file, You can obtain one at http://mozilla.org/MPL/2.0/.
+#
+
+$(eval $(call gb_Module_Module,test))
+
+ifneq (,$(filter DESKTOP,$(BUILD_TYPE)))
+
+$(eval $(call gb_Module_add_targets,test,\
+ Library_test \
+ Library_test_setupvcl \
+ Library_subsequenttest \
+ Library_vclbootstrapprotector \
+ Package_unittest \
+))
+
+$(eval $(call gb_Module_add_check_targets,test,\
+ CppunitTest_test_xpath \
+))
+
+endif
+
+# vim: set noet sw=4 ts=4: