summaryrefslogtreecommitdiffstats
path: root/tools/CustomTarget_reversemap.mk
diff options
context:
space:
mode:
Diffstat (limited to 'tools/CustomTarget_reversemap.mk')
-rw-r--r--tools/CustomTarget_reversemap.mk22
1 files changed, 22 insertions, 0 deletions
diff --git a/tools/CustomTarget_reversemap.mk b/tools/CustomTarget_reversemap.mk
new file mode 100644
index 000000000..94a697f1a
--- /dev/null
+++ b/tools/CustomTarget_reversemap.mk
@@ -0,0 +1,22 @@
+#
+# This file is part of the LibreOffice project.
+#
+# This Source Code Form is subject to the terms of the Mozilla Public
+# License, v. 2.0. If a copy of the MPL was not distributed with this
+# file, You can obtain one at http://mozilla.org/MPL/2.0/.
+#
+
+$(eval $(call gb_CustomTarget_CustomTarget,tools/string))
+
+$(call gb_CustomTarget_get_target,tools/string) : \
+ $(call gb_CustomTarget_get_workdir,tools/string)/reversemap.cxx
+
+$(call gb_CustomTarget_get_workdir,tools/string)/reversemap.cxx : \
+ $(call gb_Executable_get_runtime_dependencies,bestreversemap) \
+ | $(call gb_CustomTarget_get_workdir,tools/string)/.dir
+ $(call gb_Output_announce,$(subst $(WORKDIR)/,,$@),$(true),BRM,1)
+ $(call gb_Trace_StartRange,$(subst $(WORKDIR)/,,$@),BRM)
+ $(call gb_Helper_execute,bestreversemap > $@)
+ $(call gb_Trace_EndRange,$(subst $(WORKDIR)/,,$@),BRM)
+
+# vim: set noet sw=4 ts=4: