summaryrefslogtreecommitdiffstats
path: root/unotools/JunitTest_unotools_complex.mk
diff options
context:
space:
mode:
Diffstat (limited to 'unotools/JunitTest_unotools_complex.mk')
-rw-r--r--unotools/JunitTest_unotools_complex.mk33
1 files changed, 33 insertions, 0 deletions
diff --git a/unotools/JunitTest_unotools_complex.mk b/unotools/JunitTest_unotools_complex.mk
new file mode 100644
index 000000000..a67340493
--- /dev/null
+++ b/unotools/JunitTest_unotools_complex.mk
@@ -0,0 +1,33 @@
+# -*- Mode: makefile-gmake; tab-width: 4; indent-tabs-mode: t -*-
+#
+# This file is part of the LibreOffice project.
+#
+# This Source Code Form is subject to the terms of the Mozilla Public
+# License, v. 2.0. If a copy of the MPL was not distributed with this
+# file, You can obtain one at http://mozilla.org/MPL/2.0/.
+#
+
+$(eval $(call gb_JunitTest_JunitTest,unotools_complex))
+
+$(eval $(call gb_JunitTest_use_unoapi_jars,unotools_complex))
+
+$(eval $(call gb_JunitTest_use_jars,unotools_complex,\
+ test-tools \
+))
+
+$(eval $(call gb_JunitTest_set_defs,unotools_complex,\
+ $$(DEFS) \
+))
+
+$(eval $(call gb_JunitTest_add_classes,unotools_complex,\
+ complex.tempfile.TempFileUnitTest \
+))
+
+$(eval $(call gb_JunitTest_add_sourcefiles,unotools_complex,\
+ unotools/qa/complex/tempfile/TempFileUnitTest \
+ unotools/qa/complex/tempfile/Test01 \
+ unotools/qa/complex/tempfile/Test02 \
+ unotools/qa/complex/tempfile/TestHelper \
+))
+
+# vim: set noet sw=4 ts=4: