summaryrefslogtreecommitdiffstats
path: root/uui/Module_uui.mk
diff options
context:
space:
mode:
Diffstat (limited to 'uui/Module_uui.mk')
-rw-r--r--uui/Module_uui.mk26
1 files changed, 26 insertions, 0 deletions
diff --git a/uui/Module_uui.mk b/uui/Module_uui.mk
new file mode 100644
index 000000000..e86ec3b1c
--- /dev/null
+++ b/uui/Module_uui.mk
@@ -0,0 +1,26 @@
+# -*- Mode: makefile-gmake; tab-width: 4; indent-tabs-mode: t -*-
+#
+# This file is part of the LibreOffice project.
+#
+# This Source Code Form is subject to the terms of the Mozilla Public
+# License, v. 2.0. If a copy of the MPL was not distributed with this
+# file, You can obtain one at http://mozilla.org/MPL/2.0/.
+#
+
+$(eval $(call gb_Module_Module,uui))
+
+$(eval $(call gb_Module_add_targets,uui,\
+ Library_uui \
+ UIConfig_uui \
+))
+
+$(eval $(call gb_Module_add_l10n_targets,uui,\
+ AllLangMoTarget_uui \
+))
+
+# screenshots
+$(eval $(call gb_Module_add_screenshot_targets,uui,\
+ CppunitTest_uui_dialogs_test \
+))
+
+# vim: set noet sw=4 ts=4: