summaryrefslogtreecommitdiffstats
path: root/vcl/Executable_xpmfuzzer.mk
diff options
context:
space:
mode:
Diffstat (limited to 'vcl/Executable_xpmfuzzer.mk')
-rw-r--r--vcl/Executable_xpmfuzzer.mk45
1 files changed, 45 insertions, 0 deletions
diff --git a/vcl/Executable_xpmfuzzer.mk b/vcl/Executable_xpmfuzzer.mk
new file mode 100644
index 000000000..402c53bb6
--- /dev/null
+++ b/vcl/Executable_xpmfuzzer.mk
@@ -0,0 +1,45 @@
+# -*- Mode: makefile-gmake; tab-width: 4; indent-tabs-mode: t -*-
+#
+#
+# This file is part of the LibreOffice project.
+#
+# This Source Code Form is subject to the terms of the Mozilla Public
+# License, v. 2.0. If a copy of the MPL was not distributed with this
+# file, You can obtain one at http://mozilla.org/MPL/2.0/.
+#
+
+include $(SRCDIR)/vcl/commonfuzzer.mk
+
+$(eval $(call gb_Executable_Executable,xpmfuzzer))
+
+$(eval $(call gb_Executable_use_api,xpmfuzzer,\
+ offapi \
+ udkapi \
+))
+
+$(eval $(call gb_Executable_use_externals,xpmfuzzer,\
+ $(fuzzer_externals) \
+))
+
+$(eval $(call gb_Executable_set_include,xpmfuzzer,\
+ $$(INCLUDE) \
+ -I$(SRCDIR)/vcl/inc \
+))
+
+$(eval $(call gb_Executable_use_libraries,xpmfuzzer,\
+ $(fuzzer_core_libraries) \
+))
+
+$(eval $(call gb_Executable_use_static_libraries,xpmfuzzer,\
+ $(fuzzer_statics) \
+))
+
+$(eval $(call gb_Executable_add_exception_objects,xpmfuzzer,\
+ vcl/workben/xpmfuzzer \
+))
+
+$(eval $(call gb_Executable_add_libs,xpmfuzzer,\
+ $(LIB_FUZZING_ENGINE) \
+))
+
+# vim: set noet sw=4 ts=4: