summaryrefslogtreecommitdiffstats
path: root/vcl/StaticLibrary_vclmain.mk
diff options
context:
space:
mode:
Diffstat (limited to 'vcl/StaticLibrary_vclmain.mk')
-rw-r--r--vcl/StaticLibrary_vclmain.mk42
1 files changed, 42 insertions, 0 deletions
diff --git a/vcl/StaticLibrary_vclmain.mk b/vcl/StaticLibrary_vclmain.mk
new file mode 100644
index 000000000..cc283cc0d
--- /dev/null
+++ b/vcl/StaticLibrary_vclmain.mk
@@ -0,0 +1,42 @@
+# -*- Mode: makefile-gmake; tab-width: 4; indent-tabs-mode: t -*-
+#
+# This file is part of the LibreOffice project.
+#
+# This Source Code Form is subject to the terms of the Mozilla Public
+# License, v. 2.0. If a copy of the MPL was not distributed with this
+# file, You can obtain one at http://mozilla.org/MPL/2.0/.
+#
+# This file incorporates work covered by the following license notice:
+#
+# Licensed to the Apache Software Foundation (ASF) under one or more
+# contributor license agreements. See the NOTICE file distributed
+# with this work for additional information regarding copyright
+# ownership. The ASF licenses this file to you under the Apache
+# License, Version 2.0 (the "License"); you may not use this file
+# except in compliance with the License. You may obtain a copy of
+# the License at http://www.apache.org/licenses/LICENSE-2.0 .
+#
+
+$(eval $(call gb_StaticLibrary_StaticLibrary,vclmain))
+
+ifeq ($(OS),iOS)
+$(eval $(call gb_StaticLibrary_add_cxxflags,vclmain,\
+ $(gb_OBJCXXFLAGS) \
+))
+endif
+
+$(eval $(call gb_StaticLibrary_set_include,vclmain,\
+ $$(INCLUDE) \
+ -I$(SRCDIR)/vcl/inc \
+))
+
+$(eval $(call gb_StaticLibrary_use_api,vclmain,\
+ offapi \
+ udkapi \
+))
+
+$(eval $(call gb_StaticLibrary_add_exception_objects,vclmain,\
+ vcl/source/salmain/salmain \
+))
+
+# vim: set noet sw=4 ts=4: