summaryrefslogtreecommitdiffstats
path: root/debian/rules.d/arch
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 18:49:59 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 18:49:59 +0000
commit01997497f915e8f79871f3f2acb55ac465051d24 (patch)
tree1ce1afd7246e1014199e15cbf854bf7924458e5d /debian/rules.d/arch
parentAdding upstream version 6.1.76. (diff)
downloadlinux-01997497f915e8f79871f3f2acb55ac465051d24.tar.xz
linux-01997497f915e8f79871f3f2acb55ac465051d24.zip
Adding debian version 6.1.76-1.debian/6.1.76-1debian
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'debian/rules.d/arch')
-rw-r--r--debian/rules.d/arch/powerpc/boot/Makefile18
1 files changed, 18 insertions, 0 deletions
diff --git a/debian/rules.d/arch/powerpc/boot/Makefile b/debian/rules.d/arch/powerpc/boot/Makefile
new file mode 100644
index 000000000..9dc418f26
--- /dev/null
+++ b/debian/rules.d/arch/powerpc/boot/Makefile
@@ -0,0 +1,18 @@
+PROGS = \
+ addnote \
+ hack-coff \
+ mktree
+
+SCRIPTS = \
+ wrapper
+
+include $(top_rulesdir)/Makefile.inc
+
+CPPFLAGS += -D_LARGEFILE64_SOURCE -D_FILE_OFFSET_BITS=64
+
+# gcc for ppc64 currently seems to be treating -I like -isystem, and
+# since arch/powerpc/boot has substitute versions of some standard
+# headers for use at boot time, they are also included in these tools.
+# In this case there is actually no need to use the -I option, so
+# filter it out.
+CPPFLAGS := $(filter-out -I%,$(CPPFLAGS))