summaryrefslogtreecommitdiffstats
path: root/drivers/eisa/Makefile
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 18:49:45 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 18:49:45 +0000
commit2c3c1048746a4622d8c89a29670120dc8fab93c4 (patch)
tree848558de17fb3008cdf4d861b01ac7781903ce39 /drivers/eisa/Makefile
parentInitial commit. (diff)
downloadlinux-2c3c1048746a4622d8c89a29670120dc8fab93c4.tar.xz
linux-2c3c1048746a4622d8c89a29670120dc8fab93c4.zip
Adding upstream version 6.1.76.upstream/6.1.76upstream
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'drivers/eisa/Makefile')
-rw-r--r--drivers/eisa/Makefile22
1 files changed, 22 insertions, 0 deletions
diff --git a/drivers/eisa/Makefile b/drivers/eisa/Makefile
new file mode 100644
index 000000000..a1dd0eaec
--- /dev/null
+++ b/drivers/eisa/Makefile
@@ -0,0 +1,22 @@
+# SPDX-License-Identifier: GPL-2.0
+# Makefile for the Linux device tree
+
+obj-$(CONFIG_EISA) += eisa-bus.o
+obj-${CONFIG_EISA_PCI_EISA} += pci_eisa.o
+
+# virtual_root.o should be the last EISA root device to initialize,
+# so leave it at the end of the list.
+obj-${CONFIG_EISA_VIRTUAL_ROOT} += virtual_root.o
+
+
+# Ugly hack to get DEVICE_NAME_SIZE value...
+DEVICE_NAME_SIZE = 50
+
+$(obj)/eisa-bus.o: $(obj)/devlist.h
+
+quiet_cmd_eisaid = GEN $@
+ cmd_eisaid = sed -e '/^\#/D' -e 's/^\([[:alnum:]]\{7\}\) \+"\([^"]\{1,$(DEVICE_NAME_SIZE)\}\).*"/EISA_DEVINFO ("\1", "\2"),/' $< > $@
+
+clean-files := devlist.h
+$(obj)/devlist.h: $(src)/eisa.ids include/linux/device.h
+ $(call cmd,eisaid)