summaryrefslogtreecommitdiffstats
path: root/arch/m68k/mm/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'arch/m68k/mm/Makefile')
-rw-r--r--arch/m68k/mm/Makefile12
1 files changed, 12 insertions, 0 deletions
diff --git a/arch/m68k/mm/Makefile b/arch/m68k/mm/Makefile
new file mode 100644
index 000000000..b3adb5253
--- /dev/null
+++ b/arch/m68k/mm/Makefile
@@ -0,0 +1,12 @@
+# SPDX-License-Identifier: GPL-2.0
+#
+# Makefile for the linux m68k-specific parts of the memory manager.
+#
+
+obj-y := init.o
+
+obj-$(CONFIG_MMU) += cache.o fault.o
+obj-$(CONFIG_MMU_MOTOROLA) += kmap.o memory.o motorola.o hwtest.o
+obj-$(CONFIG_MMU_SUN3) += sun3kmap.o sun3mmu.o hwtest.o
+obj-$(CONFIG_MMU_COLDFIRE) += kmap.o memory.o mcfmmu.o
+