summaryrefslogtreecommitdiffstats
path: root/arch/microblaze/boot/dts/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'arch/microblaze/boot/dts/Makefile')
-rw-r--r--arch/microblaze/boot/dts/Makefile20
1 files changed, 20 insertions, 0 deletions
diff --git a/arch/microblaze/boot/dts/Makefile b/arch/microblaze/boot/dts/Makefile
new file mode 100644
index 000000000..b84e2cbb2
--- /dev/null
+++ b/arch/microblaze/boot/dts/Makefile
@@ -0,0 +1,20 @@
+# SPDX-License-Identifier: GPL-2.0
+#
+
+dtb-y := system.dtb
+
+ifneq ($(DTB),)
+obj-y += linked_dtb.o
+
+# Ensure system.dtb exists
+$(obj)/linked_dtb.o: $(obj)/system.dtb
+
+# Generate system.dtb from $(DTB).dtb
+ifneq ($(DTB),system)
+$(obj)/system.dtb: $(obj)/$(DTB).dtb
+ $(call if_changed,copy)
+endif
+endif
+
+# Rule to build device tree blobs
+DTC_FLAGS := -p 1024