summaryrefslogtreecommitdiffstats
path: root/arch/mips/boot/dts/ingenic/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'arch/mips/boot/dts/ingenic/Makefile')
-rw-r--r--arch/mips/boot/dts/ingenic/Makefile9
1 files changed, 9 insertions, 0 deletions
diff --git a/arch/mips/boot/dts/ingenic/Makefile b/arch/mips/boot/dts/ingenic/Makefile
new file mode 100644
index 000000000..54aa0c4e6
--- /dev/null
+++ b/arch/mips/boot/dts/ingenic/Makefile
@@ -0,0 +1,9 @@
+# SPDX-License-Identifier: GPL-2.0
+dtb-$(CONFIG_JZ4740_QI_LB60) += qi_lb60.dtb
+dtb-$(CONFIG_JZ4740_RS90) += rs90.dtb
+dtb-$(CONFIG_JZ4770_GCW0) += gcw0.dtb
+dtb-$(CONFIG_JZ4780_CI20) += ci20.dtb
+dtb-$(CONFIG_X1000_CU1000_NEO) += cu1000-neo.dtb
+dtb-$(CONFIG_X1830_CU1830_NEO) += cu1830-neo.dtb
+
+obj-$(CONFIG_BUILTIN_DTB) += $(addsuffix .o, $(dtb-y))