summaryrefslogtreecommitdiffstats
path: root/arch/mips/fw/arc/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'arch/mips/fw/arc/Makefile')
-rw-r--r--arch/mips/fw/arc/Makefile15
1 files changed, 15 insertions, 0 deletions
diff --git a/arch/mips/fw/arc/Makefile b/arch/mips/fw/arc/Makefile
new file mode 100644
index 000000000..64d685efc
--- /dev/null
+++ b/arch/mips/fw/arc/Makefile
@@ -0,0 +1,15 @@
+# SPDX-License-Identifier: GPL-2.0
+#
+# Makefile for the ARC prom monitor library routines under Linux.
+#
+
+ifdef CONFIG_ARC_CMDLINE_ONLY
+lib-y += cmdline.o
+else
+lib-y += cmdline.o env.o file.o identify.o init.o \
+ misc.o
+endif
+
+lib-$(CONFIG_ARC_MEMORY) += memory.o
+lib-$(CONFIG_ARC_CONSOLE) += arc_con.o
+lib-$(CONFIG_ARC_PROMLIB) += promlib.o