summaryrefslogtreecommitdiffstats
path: root/arch/mips/loongson32/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'arch/mips/loongson32/Makefile')
-rw-r--r--arch/mips/loongson32/Makefile18
1 files changed, 18 insertions, 0 deletions
diff --git a/arch/mips/loongson32/Makefile b/arch/mips/loongson32/Makefile
new file mode 100644
index 000000000..ba10954b4
--- /dev/null
+++ b/arch/mips/loongson32/Makefile
@@ -0,0 +1,18 @@
+# SPDX-License-Identifier: GPL-2.0-only
+#
+# Common code for all Loongson 1 based systems
+#
+
+obj-$(CONFIG_MACH_LOONGSON32) += common/
+
+#
+# Loongson LS1B board
+#
+
+obj-$(CONFIG_LOONGSON1_LS1B) += ls1b/
+
+#
+# Loongson LS1C board
+#
+
+obj-$(CONFIG_LOONGSON1_LS1C) += ls1c/