summaryrefslogtreecommitdiffstats
path: root/arch/mips/loongson64/Makefile
diff options
context:
space:
mode:
Diffstat (limited to '')
-rw-r--r--arch/mips/loongson64/Makefile14
1 files changed, 14 insertions, 0 deletions
diff --git a/arch/mips/loongson64/Makefile b/arch/mips/loongson64/Makefile
new file mode 100644
index 000000000..e806280bb
--- /dev/null
+++ b/arch/mips/loongson64/Makefile
@@ -0,0 +1,14 @@
+# SPDX-License-Identifier: GPL-2.0-only
+#
+# Makefile for Loongson-3 family machines
+#
+obj-$(CONFIG_MACH_LOONGSON64) += cop2-ex.o dma.o \
+ setup.o init.o env.o time.o reset.o \
+
+obj-$(CONFIG_SMP) += smp.o
+obj-$(CONFIG_NUMA) += numa.o
+obj-$(CONFIG_RS780_HPET) += hpet.o
+obj-$(CONFIG_SUSPEND) += pm.o
+obj-$(CONFIG_PCI_QUIRKS) += vbios_quirk.o
+obj-$(CONFIG_CPU_LOONGSON3_CPUCFG_EMULATION) += cpucfg-emul.o
+obj-$(CONFIG_SYSFS) += boardinfo.o