summaryrefslogtreecommitdiffstats
path: root/arch/parisc/boot/Makefile
diff options
context:
space:
mode:
Diffstat (limited to '')
-rw-r--r--arch/parisc/boot/Makefile17
1 files changed, 17 insertions, 0 deletions
diff --git a/arch/parisc/boot/Makefile b/arch/parisc/boot/Makefile
new file mode 100644
index 000000000..b873ee472
--- /dev/null
+++ b/arch/parisc/boot/Makefile
@@ -0,0 +1,17 @@
+# SPDX-License-Identifier: GPL-2.0-only
+#
+# Makefile for the linux parisc-specific parts of the boot image creator.
+#
+
+targets := image
+targets += bzImage
+subdir- := compressed
+
+$(obj)/image: vmlinux FORCE
+ $(call if_changed,objcopy)
+
+$(obj)/bzImage: $(obj)/compressed/vmlinux FORCE
+ $(call if_changed,objcopy)
+
+$(obj)/compressed/vmlinux: FORCE
+ $(Q)$(MAKE) $(build)=$(obj)/compressed $@