summaryrefslogtreecommitdiffstats
path: root/arch/riscv/net/Makefile
diff options
context:
space:
mode:
Diffstat (limited to '')
-rw-r--r--arch/riscv/net/Makefile9
1 files changed, 9 insertions, 0 deletions
diff --git a/arch/riscv/net/Makefile b/arch/riscv/net/Makefile
new file mode 100644
index 000000000..9a1e5f0a9
--- /dev/null
+++ b/arch/riscv/net/Makefile
@@ -0,0 +1,9 @@
+# SPDX-License-Identifier: GPL-2.0-only
+
+obj-$(CONFIG_BPF_JIT) += bpf_jit_core.o
+
+ifeq ($(CONFIG_ARCH_RV64I),y)
+ obj-$(CONFIG_BPF_JIT) += bpf_jit_comp64.o
+else
+ obj-$(CONFIG_BPF_JIT) += bpf_jit_comp32.o
+endif