summaryrefslogtreecommitdiffstats
path: root/arch/sh/tools/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'arch/sh/tools/Makefile')
-rw-r--r--arch/sh/tools/Makefile16
1 files changed, 16 insertions, 0 deletions
diff --git a/arch/sh/tools/Makefile b/arch/sh/tools/Makefile
new file mode 100644
index 000000000..e5ba31c79
--- /dev/null
+++ b/arch/sh/tools/Makefile
@@ -0,0 +1,16 @@
+#
+# arch/sh/tools/Makefile
+#
+# Copyright (C) 2003 Paul Mundt
+#
+# This file is subject to the terms and conditions of the GNU General Public
+# License. See the file "COPYING" in the main directory of this archive
+# for more details.
+#
+# Shamelessly cloned from ARM.
+#
+
+include/generated/machtypes.h: $(src)/gen-mach-types $(src)/mach-types
+ @echo ' Generating $@'
+ $(Q)mkdir -p $(dir $@)
+ $(Q)LC_ALL=C $(AWK) -f $^ > $@