summaryrefslogtreecommitdiffstats
path: root/arch/xtensa/boot/dts/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'arch/xtensa/boot/dts/Makefile')
-rw-r--r--arch/xtensa/boot/dts/Makefile14
1 files changed, 14 insertions, 0 deletions
diff --git a/arch/xtensa/boot/dts/Makefile b/arch/xtensa/boot/dts/Makefile
new file mode 100644
index 000000000..720628c0d
--- /dev/null
+++ b/arch/xtensa/boot/dts/Makefile
@@ -0,0 +1,14 @@
+#
+# arch/xtensa/boot/dts/Makefile
+#
+# This file is subject to the terms and conditions of the GNU General Public
+# License. See the file "COPYING" in the main directory of this archive
+# for more details.
+#
+#
+
+obj-$(CONFIG_OF) += $(addsuffix .dtb.o, $(CONFIG_BUILTIN_DTB_SOURCE))
+
+# for CONFIG_OF_ALL_DTBS test
+dtstree := $(srctree)/$(src)
+dtb- := $(patsubst $(dtstree)/%.dts,%.dtb, $(wildcard $(dtstree)/*.dts))