summaryrefslogtreecommitdiffstats
path: root/drivers/cxl/core/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'drivers/cxl/core/Makefile')
-rw-r--r--drivers/cxl/core/Makefile13
1 files changed, 13 insertions, 0 deletions
diff --git a/drivers/cxl/core/Makefile b/drivers/cxl/core/Makefile
new file mode 100644
index 000000000..79c7257f4
--- /dev/null
+++ b/drivers/cxl/core/Makefile
@@ -0,0 +1,13 @@
+# SPDX-License-Identifier: GPL-2.0
+obj-$(CONFIG_CXL_BUS) += cxl_core.o
+obj-$(CONFIG_CXL_SUSPEND) += suspend.o
+
+ccflags-y += -I$(srctree)/drivers/cxl
+cxl_core-y := port.o
+cxl_core-y += pmem.o
+cxl_core-y += regs.o
+cxl_core-y += memdev.o
+cxl_core-y += mbox.o
+cxl_core-y += pci.o
+cxl_core-y += hdm.o
+cxl_core-$(CONFIG_CXL_REGION) += region.o