summaryrefslogtreecommitdiffstats
path: root/drivers/macintosh/ams/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'drivers/macintosh/ams/Makefile')
-rw-r--r--drivers/macintosh/ams/Makefile9
1 files changed, 9 insertions, 0 deletions
diff --git a/drivers/macintosh/ams/Makefile b/drivers/macintosh/ams/Makefile
new file mode 100644
index 000000000..3b58d02c9
--- /dev/null
+++ b/drivers/macintosh/ams/Makefile
@@ -0,0 +1,9 @@
+# SPDX-License-Identifier: GPL-2.0-only
+#
+# Makefile for Apple Motion Sensor driver
+#
+
+ams-y := ams-core.o ams-input.o
+ams-$(CONFIG_SENSORS_AMS_PMU) += ams-pmu.o
+ams-$(CONFIG_SENSORS_AMS_I2C) += ams-i2c.o
+obj-$(CONFIG_SENSORS_AMS) += ams.o