summaryrefslogtreecommitdiffstats
path: root/drivers/usb/core/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'drivers/usb/core/Makefile')
-rw-r--r--drivers/usb/core/Makefile21
1 files changed, 21 insertions, 0 deletions
diff --git a/drivers/usb/core/Makefile b/drivers/usb/core/Makefile
new file mode 100644
index 000000000..7d338e9c0
--- /dev/null
+++ b/drivers/usb/core/Makefile
@@ -0,0 +1,21 @@
+# SPDX-License-Identifier: GPL-2.0
+#
+# Makefile for USB Core files and filesystem
+#
+
+usbcore-y := usb.o hub.o hcd.o urb.o message.o driver.o
+usbcore-y += config.o file.o buffer.o sysfs.o endpoint.o
+usbcore-y += devio.o notify.o generic.o quirks.o devices.o
+usbcore-y += phy.o port.o
+
+usbcore-$(CONFIG_OF) += of.o
+usbcore-$(CONFIG_USB_PCI) += hcd-pci.o
+usbcore-$(CONFIG_ACPI) += usb-acpi.o
+
+ifdef CONFIG_USB_ONBOARD_HUB
+usbcore-y += ../misc/onboard_usb_hub_pdevs.o
+endif
+
+obj-$(CONFIG_USB) += usbcore.o
+
+obj-$(CONFIG_USB_LEDS_TRIGGER_USBPORT) += ledtrig-usbport.o