summaryrefslogtreecommitdiffstats
path: root/lib/kunit/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'lib/kunit/Makefile')
-rw-r--r--lib/kunit/Makefile21
1 files changed, 21 insertions, 0 deletions
diff --git a/lib/kunit/Makefile b/lib/kunit/Makefile
new file mode 100644
index 000000000..29aff6562
--- /dev/null
+++ b/lib/kunit/Makefile
@@ -0,0 +1,21 @@
+obj-$(CONFIG_KUNIT) += kunit.o
+
+kunit-objs += test.o \
+ resource.o \
+ string-stream.o \
+ assert.o \
+ try-catch.o \
+ executor.o
+
+ifeq ($(CONFIG_KUNIT_DEBUGFS),y)
+kunit-objs += debugfs.o
+endif
+
+obj-$(CONFIG_KUNIT_TEST) += kunit-test.o
+
+# string-stream-test compiles built-in only.
+ifeq ($(CONFIG_KUNIT_TEST),y)
+obj-$(CONFIG_KUNIT_TEST) += string-stream-test.o
+endif
+
+obj-$(CONFIG_KUNIT_EXAMPLE_TEST) += kunit-example-test.o