summaryrefslogtreecommitdiffstats
path: root/sound/pci/cs5535audio/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'sound/pci/cs5535audio/Makefile')
-rw-r--r--sound/pci/cs5535audio/Makefile11
1 files changed, 11 insertions, 0 deletions
diff --git a/sound/pci/cs5535audio/Makefile b/sound/pci/cs5535audio/Makefile
new file mode 100644
index 000000000..447e62875
--- /dev/null
+++ b/sound/pci/cs5535audio/Makefile
@@ -0,0 +1,11 @@
+# SPDX-License-Identifier: GPL-2.0-only
+#
+# Makefile for cs5535audio
+#
+
+snd-cs5535audio-y := cs5535audio.o cs5535audio_pcm.o
+snd-cs5535audio-$(CONFIG_PM_SLEEP) += cs5535audio_pm.o
+snd-cs5535audio-$(CONFIG_OLPC) += cs5535audio_olpc.o
+
+# Toplevel Module Dependency
+obj-$(CONFIG_SND_CS5535AUDIO) += snd-cs5535audio.o