summaryrefslogtreecommitdiffstats
path: root/debian/rules
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 18:39:51 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 18:39:51 +0000
commit9db16bb1022d07845b5e17880b10b290625ac312 (patch)
tree869a644221867ae01a0dd117a76fb3cdc5f406a5 /debian/rules
parentAdding upstream version 1:43+1. (diff)
downloadmeta-gnome3-9db16bb1022d07845b5e17880b10b290625ac312.tar.xz
meta-gnome3-9db16bb1022d07845b5e17880b10b290625ac312.zip
Adding debian version 1:43+1.debian/1%43+1debian
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules16
1 files changed, 16 insertions, 0 deletions
diff --git a/debian/rules b/debian/rules
new file mode 100755
index 0000000..87f24e2
--- /dev/null
+++ b/debian/rules
@@ -0,0 +1,16 @@
+#!/usr/bin/make -f
+# -*- mode: makefile; coding: utf-8 -*-
+
+%:
+ dh $@
+
+override_dh_gnome:
+ dh_gnome --no-gnome-versions
+
+# In Ubuntu, low-memory-monitor is not in main
+override_dh_gencontrol:
+ifneq ($(shell dpkg-vendor --query vendor),Ubuntu)
+ dh_gencontrol -- -Vlmm:Recommends='low-memory-monitor [linux-any]'
+else
+ dh_gencontrol
+endif