summaryrefslogtreecommitdiffstats
path: root/test/automated/display/meson.build
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 17:39:48 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 17:39:48 +0000
commit3ade071f273aaa973e44bf95d6b1d4913a18f03b (patch)
treee2f99d267ae18427645404f215b984afbe73098d /test/automated/display/meson.build
parentInitial commit. (diff)
downloadnautilus-3ade071f273aaa973e44bf95d6b1d4913a18f03b.tar.xz
nautilus-3ade071f273aaa973e44bf95d6b1d4913a18f03b.zip
Adding upstream version 43.2.upstream/43.2upstream
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'test/automated/display/meson.build')
-rw-r--r--test/automated/display/meson.build23
1 files changed, 23 insertions, 0 deletions
diff --git a/test/automated/display/meson.build b/test/automated/display/meson.build
new file mode 100644
index 0000000..a7e2e0b
--- /dev/null
+++ b/test/automated/display/meson.build
@@ -0,0 +1,23 @@
+test_env += [
+ 'G_TEST_BUILDDIR=@0@'.format(meson.current_build_dir()),
+ 'G_TEST_SRCDIR=@0@'.format(meson.current_source_dir())
+]
+
+tests = [
+ ['test-nautilus-directory-async', [
+ 'test-nautilus-directory-async.c'
+ ]],
+]
+
+foreach t: tests
+ test(
+ t[0],
+ executable(t[0], t[1], dependencies: libnautilus_dep),
+ env: [
+ test_env,
+ 'G_TEST_BUILDDIR=@0@'.format(meson.current_build_dir()),
+ 'G_TEST_SRCDIR=@0@'.format(meson.current_source_dir())
+ ],
+ timeout: 480
+ )
+endforeach