summaryrefslogtreecommitdiffstats
path: root/extensions/audio-video-properties/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'extensions/audio-video-properties/meson.build')
-rw-r--r--extensions/audio-video-properties/meson.build26
1 files changed, 26 insertions, 0 deletions
diff --git a/extensions/audio-video-properties/meson.build b/extensions/audio-video-properties/meson.build
new file mode 100644
index 0000000..e78e7f6
--- /dev/null
+++ b/extensions/audio-video-properties/meson.build
@@ -0,0 +1,26 @@
+libm = cc.find_library('m')
+
+libtotem_properties_page_sources = files(
+ 'totem-properties-main.c',
+ 'totem-properties-view.c',
+ 'totem-gst-helpers.c',
+)
+
+libtotem_properties_page_deps = [
+ libm,
+ gst_tag_dep,
+ gst_pbutils_dep,
+]
+
+libtotem_properties_page = shared_module(
+ 'totem-properties-page',
+ sources: libtotem_properties_page_sources,
+ dependencies: libtotem_properties_page_deps + [
+ nautilus_extension
+ ],
+ c_args: [
+ '-DG_LOG_DOMAIN="TotemPropertiesPage"'
+ ],
+ install: true,
+ install_dir: extensiondir
+)