summaryrefslogtreecommitdiffstats
path: root/test/automated/display/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'test/automated/display/meson.build')
-rw-r--r--test/automated/display/meson.build23
1 files changed, 23 insertions, 0 deletions
diff --git a/test/automated/display/meson.build b/test/automated/display/meson.build
new file mode 100644
index 0000000..a7e2e0b
--- /dev/null
+++ b/test/automated/display/meson.build
@@ -0,0 +1,23 @@
+test_env += [
+ 'G_TEST_BUILDDIR=@0@'.format(meson.current_build_dir()),
+ 'G_TEST_SRCDIR=@0@'.format(meson.current_source_dir())
+]
+
+tests = [
+ ['test-nautilus-directory-async', [
+ 'test-nautilus-directory-async.c'
+ ]],
+]
+
+foreach t: tests
+ test(
+ t[0],
+ executable(t[0], t[1], dependencies: libnautilus_dep),
+ env: [
+ test_env,
+ 'G_TEST_BUILDDIR=@0@'.format(meson.current_build_dir()),
+ 'G_TEST_SRCDIR=@0@'.format(meson.current_source_dir())
+ ],
+ timeout: 480
+ )
+endforeach