summaryrefslogtreecommitdiffstats
path: root/debian/rules
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-10 15:09:37 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-20 16:57:21 +0000
commite8993bc4c46da3e446e61e9cf70d166320047a70 (patch)
tree58aa228f93f58442f2901e3aa780170ddd4e2f42 /debian/rules
parentUpdating vcs fields. (diff)
downloadopen-infrastructure-service-tools-e8993bc4c46da3e446e61e9cf70d166320047a70.tar.xz
open-infrastructure-service-tools-e8993bc4c46da3e446e61e9cf70d166320047a70.zip
Building individual subpackages for every set of tools.
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to '')
-rwxr-xr-xdebian/rules20
1 files changed, 15 insertions, 5 deletions
diff --git a/debian/rules b/debian/rules
index 62c4dda..b3924c0 100755
--- a/debian/rules
+++ b/debian/rules
@@ -1,13 +1,23 @@
#!/usr/bin/make -f
+PACKAGES := $(shell dh_listpackages | cut -d '-' -f 3- | sed -e 's|-tools$$||')
+
%:
dh ${@} --with apache2
override_dh_auto_install:
+ for PACKAGE in $(PACKAGES); \
+ do \
+ $(MAKE) -C $${PACKAGE} DESTDIR=$(CURDIR)/debian/open-infrastructure-$${PACKAGE}-tools install; \
+ done
+
# apache-tools
- $(MAKE) -C apache DESTDIR=$(CURDIR)/debian/open-infrastructure-service-tools install
+ rm -f debian/open-infrastructure-apache-tools/usr/share/doc/apache-tools/CHANGELOG.txt
+ rm -f debian/open-infrastructure-apache-tools/usr/share/doc/apache-tools/LICENSE.txt
+ -mv debian/open-infrastructure-apache-tools/usr/share/doc/* debian/open-infrastructure-apache-tools/usr/share/doc/open-infrastructure-apache-tools
- # service-tools
- rm -f debian/open-infrastructure-service-tools/usr/share/doc/service-tools/CHANGELOG.txt
- rm -f debian/open-infrastructure-service-tools/usr/share/doc/service-tools/LICENSE.txt
- -mv debian/open-infrastructure-service-tools/usr/share/doc/* debian/open-infrastructure-service-tools/usr/share/doc/open-infrastructure-service-tools
+ifeq (open-infrastructure-linux-tools,$(findstring open-infrastructure-linux-tools,$(PACKAGES)))
+override_dh_installsystemd:
+ dh_installsystemd -p open-infrastructure-linux-tools --no-restart-after-upgrade --no-start --no-stop-on-upgrade
+ dh_installsystemd --remaining-packages
+endif