summaryrefslogtreecommitdiffstats
path: root/.cirrus.yml
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 18:28:17 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 18:28:17 +0000
commit7a46c07230b8d8108c0e8e80df4522d0ac116538 (patch)
treed483300dab478b994fe199a5d19d18d74153718a /.cirrus.yml
parentInitial commit. (diff)
downloadpipewire-7a46c07230b8d8108c0e8e80df4522d0ac116538.tar.xz
pipewire-7a46c07230b8d8108c0e8e80df4522d0ac116538.zip
Adding upstream version 0.3.65.upstream/0.3.65upstream
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to '.cirrus.yml')
-rw-r--r--.cirrus.yml24
1 files changed, 24 insertions, 0 deletions
diff --git a/.cirrus.yml b/.cirrus.yml
new file mode 100644
index 0000000..d26c443
--- /dev/null
+++ b/.cirrus.yml
@@ -0,0 +1,24 @@
+task:
+ freebsd_instance:
+ matrix:
+ - image_family: freebsd-13-1-snap
+ env:
+ # /usr/ports/Mk/Uses/localbase.mk localbase:ldflags
+ LOCALBASE: /usr/local
+ CFLAGS: -isystem $LOCALBASE/include
+ CPPFLAGS: $CFLAGS
+ CXXFLAGS: $CFLAGS
+ LDFLAGS: -L$LOCALBASE/lib
+ deps_script:
+ - sed -i.bak -e 's/quarterly/latest/' /etc/pkg/FreeBSD.conf
+ - pkg install -y meson pkgconf git-lite dbus glib libepoll-shim libudev-devd vulkan-loader vulkan-headers v4l_compat gstreamer1 gstreamer1-plugins libinotify gettext libsndfile sdl2 alsa-lib
+ - sysrc dbus_enable=YES
+ - service dbus restart
+ build_script:
+ - mkdir build
+ - cd build
+ - meson setup -Dalsa=enabled -Draop=enabled -Dv4l2=enabled -Dpipewire-alsa=enabled -Dbluez5=disabled -Djack=disabled -Dpipewire-jack=enabled -Dpw-cat=enabled -Dpipewire-v4l2=disabled -Dsdl2=enabled -Dsystemd=disabled -Dsession-managers=media-session ..
+ - ninja
+ test_script:
+ - cd build
+ - ninja test