summaryrefslogtreecommitdiffstats
path: root/spa/plugins/vulkan/meson.build
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 18:28:17 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 18:28:17 +0000
commit7a46c07230b8d8108c0e8e80df4522d0ac116538 (patch)
treed483300dab478b994fe199a5d19d18d74153718a /spa/plugins/vulkan/meson.build
parentInitial commit. (diff)
downloadpipewire-upstream.tar.xz
pipewire-upstream.zip
Adding upstream version 0.3.65.upstream/0.3.65upstream
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to '')
-rw-r--r--spa/plugins/vulkan/meson.build12
1 files changed, 12 insertions, 0 deletions
diff --git a/spa/plugins/vulkan/meson.build b/spa/plugins/vulkan/meson.build
new file mode 100644
index 0000000..0657d21
--- /dev/null
+++ b/spa/plugins/vulkan/meson.build
@@ -0,0 +1,12 @@
+spa_vulkan_sources = [
+ 'plugin.c',
+ 'vulkan-compute-filter.c',
+ 'vulkan-compute-source.c',
+ 'vulkan-utils.c'
+]
+
+spa_vulkan = shared_library('spa-vulkan',
+ spa_vulkan_sources,
+ dependencies : [ spa_dep, vulkan_dep, mathlib ],
+ install : true,
+ install_dir : spa_plugindir / 'vulkan')