summaryrefslogtreecommitdiffstats
path: root/autogen.sh
diff options
context:
space:
mode:
Diffstat (limited to '')
-rwxr-xr-xautogen.sh18
1 files changed, 18 insertions, 0 deletions
diff --git a/autogen.sh b/autogen.sh
new file mode 100755
index 0000000..5e0c381
--- /dev/null
+++ b/autogen.sh
@@ -0,0 +1,18 @@
+#!/bin/sh
+
+# Only there to make jhbuild happy
+
+if [ -z "$MESON" ]; then
+ MESON=$(which meson)
+fi
+if [ -z "$MESON" ]; then
+ echo "error: Meson not found."
+ echo "Install meson to configure and build PipeWire. If meson" \
+ "is already installed, set the environment variable MESON" \
+ "to the binary's path."
+ exit 1;
+fi
+
+mkdir -p builddir
+$MESON setup "$@" builddir # use 'autogen.sh --reconfigure' to update
+ln -sf builddir/Makefile Makefile