summaryrefslogtreecommitdiffstats
path: root/spa/plugins/ffmpeg/meson.build
diff options
context:
space:
mode:
Diffstat (limited to '')
-rw-r--r--spa/plugins/ffmpeg/meson.build9
1 files changed, 9 insertions, 0 deletions
diff --git a/spa/plugins/ffmpeg/meson.build b/spa/plugins/ffmpeg/meson.build
new file mode 100644
index 0000000..0e41ecb
--- /dev/null
+++ b/spa/plugins/ffmpeg/meson.build
@@ -0,0 +1,9 @@
+ffmpeg_sources = ['ffmpeg.c',
+ 'ffmpeg-dec.c',
+ 'ffmpeg-enc.c']
+
+ffmpeglib = shared_library('spa-ffmpeg',
+ ffmpeg_sources,
+ dependencies : [ spa_dep, avcodec_dep ],
+ install : true,
+ install_dir : spa_plugindir / 'ffmpeg')