summaryrefslogtreecommitdiffstats
path: root/spa/plugins/libcamera/meson.build
diff options
context:
space:
mode:
Diffstat (limited to '')
-rw-r--r--spa/plugins/libcamera/meson.build17
1 files changed, 17 insertions, 0 deletions
diff --git a/spa/plugins/libcamera/meson.build b/spa/plugins/libcamera/meson.build
new file mode 100644
index 0000000..abb1a42
--- /dev/null
+++ b/spa/plugins/libcamera/meson.build
@@ -0,0 +1,17 @@
+libcamera_sources = [
+ 'libcamera.c',
+ 'libcamera-manager.cpp',
+ 'libcamera-device.cpp',
+ 'libcamera-source.cpp'
+]
+
+libdrm_dep = dependency('libdrm', version : '>= 2.4.98',
+ required : get_option('libcamera'))
+summary({'libdrm': libdrm_dep.found()}, bool_yn: true, section: 'Backend')
+if libdrm_dep.found()
+ libcameralib = shared_library('spa-libcamera',
+ libcamera_sources,
+ dependencies : [ spa_dep, libudev_dep, libcamera_dep, pthread_lib, libdrm_dep ],
+ install : true,
+ install_dir : spa_plugindir / 'libcamera')
+endif