summaryrefslogtreecommitdiffstats
path: root/spa/plugins/v4l2/meson.build
diff options
context:
space:
mode:
Diffstat (limited to '')
-rw-r--r--spa/plugins/v4l2/meson.build10
1 files changed, 10 insertions, 0 deletions
diff --git a/spa/plugins/v4l2/meson.build b/spa/plugins/v4l2/meson.build
new file mode 100644
index 0000000..648583f
--- /dev/null
+++ b/spa/plugins/v4l2/meson.build
@@ -0,0 +1,10 @@
+v4l2_sources = ['v4l2.c',
+ 'v4l2-device.c',
+ 'v4l2-udev.c',
+ 'v4l2-source.c']
+
+v4l2lib = shared_library('spa-v4l2',
+ v4l2_sources,
+ dependencies : [ spa_dep, libudev_dep, libinotify_dep ],
+ install : true,
+ install_dir : spa_plugindir / 'v4l2')