summaryrefslogtreecommitdiffstats
path: root/shell-completion/zsh/meson.build
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 15:35:18 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 15:35:18 +0000
commitb750101eb236130cf056c675997decbac904cc49 (patch)
treea5df1a06754bdd014cb975c051c83b01c9a97532 /shell-completion/zsh/meson.build
parentInitial commit. (diff)
downloadsystemd-b750101eb236130cf056c675997decbac904cc49.tar.xz
systemd-b750101eb236130cf056c675997decbac904cc49.zip
Adding upstream version 252.22.upstream/252.22upstream
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to '')
-rw-r--r--shell-completion/zsh/meson.build48
1 files changed, 48 insertions, 0 deletions
diff --git a/shell-completion/zsh/meson.build b/shell-completion/zsh/meson.build
new file mode 100644
index 0000000..b39f933
--- /dev/null
+++ b/shell-completion/zsh/meson.build
@@ -0,0 +1,48 @@
+# SPDX-License-Identifier: LGPL-2.1-or-later
+
+zshcompletiondir = get_option('zshcompletiondir')
+if zshcompletiondir == ''
+ zshcompletiondir = datadir / 'zsh/site-functions'
+endif
+
+custom_target(
+ '_systemctl',
+ input : '_systemctl.in',
+ output : '_systemctl',
+ command : [jinja2_cmdline, '@INPUT@', '@OUTPUT@'],
+ install : zshcompletiondir != 'no',
+ install_dir : zshcompletiondir)
+
+items = [['_busctl', ''],
+ ['_journalctl', ''],
+ ['_systemd-analyze', ''],
+ ['_systemd-delta', ''],
+ ['_systemd-nspawn', ''],
+ ['_systemd', ''],
+ ['_systemd-path', ''],
+ ['_systemd-run', ''],
+ ['_udevadm', ''],
+ ['_kernel-install', 'ENABLE_KERNEL_INSTALL'],
+ ['_sd_hosts_or_user_at_host', ''],
+ ['_sd_outputmodes', ''],
+ ['_sd_unit_files', ''],
+ ['_sd_machines', ''],
+ ['_bootctl', 'HAVE_GNU_EFI'],
+ ['_coredumpctl', 'ENABLE_COREDUMP'],
+ ['_hostnamectl', 'ENABLE_HOSTNAMED'],
+ ['_localectl', 'ENABLE_LOCALED'],
+ ['_loginctl', 'ENABLE_LOGIND'],
+ ['_machinectl', 'ENABLE_MACHINED'],
+ ['_networkctl', 'ENABLE_NETWORKD'],
+ ['_oomctl', 'ENABLE_OOMD'],
+ ['_systemd-inhibit', 'ENABLE_LOGIND'],
+ ['_resolvectl', 'ENABLE_RESOLVE'],
+ ['_systemd-tmpfiles', 'ENABLE_TMPFILES'],
+ ['_timedatectl', 'ENABLE_TIMEDATED']]
+
+foreach item : items
+ if zshcompletiondir != 'no' and (item[1] == '' or conf.get(item[1]) == 1)
+ install_data(item[0],
+ install_dir : zshcompletiondir)
+ endif
+endforeach