From b750101eb236130cf056c675997decbac904cc49 Mon Sep 17 00:00:00 2001
From: Daniel Baumann <daniel.baumann@progress-linux.org>
Date: Sun, 7 Apr 2024 17:35:18 +0200
Subject: Adding upstream version 252.22.

Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
---
 test/TEST-13-NSPAWN-SMOKE/Makefile |  1 +
 test/TEST-13-NSPAWN-SMOKE/test.sh  | 30 ++++++++++++++++++++++++++++++
 2 files changed, 31 insertions(+)
 create mode 120000 test/TEST-13-NSPAWN-SMOKE/Makefile
 create mode 100755 test/TEST-13-NSPAWN-SMOKE/test.sh

(limited to 'test/TEST-13-NSPAWN-SMOKE')

diff --git a/test/TEST-13-NSPAWN-SMOKE/Makefile b/test/TEST-13-NSPAWN-SMOKE/Makefile
new file mode 120000
index 0000000..e9f93b1
--- /dev/null
+++ b/test/TEST-13-NSPAWN-SMOKE/Makefile
@@ -0,0 +1 @@
+../TEST-01-BASIC/Makefile
\ No newline at end of file
diff --git a/test/TEST-13-NSPAWN-SMOKE/test.sh b/test/TEST-13-NSPAWN-SMOKE/test.sh
new file mode 100755
index 0000000..65c1e9b
--- /dev/null
+++ b/test/TEST-13-NSPAWN-SMOKE/test.sh
@@ -0,0 +1,30 @@
+#!/usr/bin/env bash
+# SPDX-License-Identifier: LGPL-2.1-or-later
+set -e
+
+TEST_DESCRIPTION="systemd-nspawn smoke test"
+IMAGE_NAME="nspawn"
+TEST_NO_NSPAWN=1
+
+# shellcheck source=test/test-functions
+. "${TEST_BASE_DIR:?}/test-functions"
+
+test_append_files() {
+    (
+        local workspace="${1:?}"
+
+        # On openSUSE the static linked version of busybox is named "busybox-static".
+        busybox="$(type -P busybox-static || type -P busybox)"
+        inst_simple "$busybox" "$(dirname "$busybox")/busybox"
+
+        if command -v selinuxenabled >/dev/null && selinuxenabled; then
+            image_install selinuxenabled
+            cp -ar /etc/selinux "$workspace/etc/selinux"
+        fi
+
+        "$TEST_BASE_DIR/create-busybox-container" "$workspace/testsuite-13.nc-container"
+        initdir="$workspace/testsuite-13.nc-container" image_install nc ip md5sum
+    )
+}
+
+do_test "$@"
-- 
cgit v1.2.3