summaryrefslogtreecommitdiffstats
path: root/comm/mail/moz.build
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 17:32:43 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 17:32:43 +0000
commit6bf0a5cb5034a7e684dcc3500e841785237ce2dd (patch)
treea68f146d7fa01f0134297619fbe7e33db084e0aa /comm/mail/moz.build
parentInitial commit. (diff)
downloadthunderbird-6bf0a5cb5034a7e684dcc3500e841785237ce2dd.tar.xz
thunderbird-6bf0a5cb5034a7e684dcc3500e841785237ce2dd.zip
Adding upstream version 1:115.7.0.upstream/1%115.7.0upstream
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'comm/mail/moz.build')
-rw-r--r--comm/mail/moz.build40
1 files changed, 40 insertions, 0 deletions
diff --git a/comm/mail/moz.build b/comm/mail/moz.build
new file mode 100644
index 0000000000..e3c02d3877
--- /dev/null
+++ b/comm/mail/moz.build
@@ -0,0 +1,40 @@
+# vim: set filetype=python:
+# This Source Code Form is subject to the terms of the Mozilla Public
+# License, v. 2.0. If a copy of the MPL was not distributed with this
+# file, You can obtain one at http://mozilla.org/MPL/2.0/.
+
+CONFIGURE_SUBST_FILES += ["installer/Makefile"]
+
+# app is always last as it packages up the built files on mac.
+DIRS += [
+ "actors",
+ "app",
+ "base",
+ "extensions",
+ "locales",
+ "modules",
+ "themes",
+]
+
+if CONFIG["MAKENSISU"]:
+ DIRS += ["installer/windows"]
+
+if CONFIG["MOZ_BUNDLED_FONTS"]:
+ DIRS += ["/browser/fonts"]
+
+if CONFIG["NIGHTLY_BUILD"]:
+ DIRS += ["services/sync"]
+
+DIRS += [
+ "../python",
+ "../taskcluster",
+ "../third_party",
+]
+
+TEST_DIRS += [
+ "test/browser",
+ "test/marionette",
+ "test/static",
+]
+
+FINAL_TARGET_FILES.defaults += ["app/permissions"]