summaryrefslogtreecommitdiffstats
path: root/comm/mailnews/compose/test/unit/test_smtpURL.js
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 17:32:43 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 17:32:43 +0000
commit6bf0a5cb5034a7e684dcc3500e841785237ce2dd (patch)
treea68f146d7fa01f0134297619fbe7e33db084e0aa /comm/mailnews/compose/test/unit/test_smtpURL.js
parentInitial commit. (diff)
downloadthunderbird-6bf0a5cb5034a7e684dcc3500e841785237ce2dd.tar.xz
thunderbird-6bf0a5cb5034a7e684dcc3500e841785237ce2dd.zip
Adding upstream version 1:115.7.0.upstream/1%115.7.0upstream
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'comm/mailnews/compose/test/unit/test_smtpURL.js')
-rw-r--r--comm/mailnews/compose/test/unit/test_smtpURL.js30
1 files changed, 30 insertions, 0 deletions
diff --git a/comm/mailnews/compose/test/unit/test_smtpURL.js b/comm/mailnews/compose/test/unit/test_smtpURL.js
new file mode 100644
index 0000000000..833ca91817
--- /dev/null
+++ b/comm/mailnews/compose/test/unit/test_smtpURL.js
@@ -0,0 +1,30 @@
+/* -*- Mode: C++; tab-width: 2; indent-tabs-mode: nil; c-basic-offset: 2 -*- */
+/*
+ * Test suite for checking SMTP URLs are working as expected.
+ * XXX this test needs extending as we fix up nsSmtpUrl.
+ */
+
+var smtpURLs = [
+ {
+ url: "smtp://user@localhost/",
+ spec: "smtp://user@localhost/",
+ username: "user",
+ },
+ {
+ url: "smtps://user@localhost/",
+ spec: "smtps://user@localhost/",
+ username: "user",
+ },
+];
+
+function run_test() {
+ var url;
+ for (var part = 0; part < smtpURLs.length; ++part) {
+ print("url: " + smtpURLs[part].url);
+
+ url = Services.io.newURI(smtpURLs[part].url);
+
+ Assert.equal(url.spec, smtpURLs[part].spec);
+ Assert.equal(url.username, smtpURLs[part].username);
+ }
+}