summaryrefslogtreecommitdiffstats
path: root/comm/third_party/Makefile.in
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 17:32:43 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 17:32:43 +0000
commit6bf0a5cb5034a7e684dcc3500e841785237ce2dd (patch)
treea68f146d7fa01f0134297619fbe7e33db084e0aa /comm/third_party/Makefile.in
parentInitial commit. (diff)
downloadthunderbird-6bf0a5cb5034a7e684dcc3500e841785237ce2dd.tar.xz
thunderbird-6bf0a5cb5034a7e684dcc3500e841785237ce2dd.zip
Adding upstream version 1:115.7.0.upstream/1%115.7.0upstream
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'comm/third_party/Makefile.in')
-rw-r--r--comm/third_party/Makefile.in31
1 files changed, 31 insertions, 0 deletions
diff --git a/comm/third_party/Makefile.in b/comm/third_party/Makefile.in
new file mode 100644
index 0000000000..fc5e8d2440
--- /dev/null
+++ b/comm/third_party/Makefile.in
@@ -0,0 +1,31 @@
+# This Source Code Form is subject to the terms of the Mozilla Public
+# License, v. 2.0. If a copy of the MPL was not distributed with this
+# file, You can obtain one at http://mozilla.org/MPL/2.0/.
+
+
+include $(topsrcdir)/config/config.mk
+include $(topsrcdir)/config/rules.mk
+
+print-%: ; @echo $* is $($*)
+origin-%: ; @echo $* origin $(origin $*)
+
+ifdef TB_LIBOTR_PREBUILT
+
+ifeq (WINNT,$(OS_ARCH))
+OTR_LIBS := libotr.dll libssp-0.dll
+endif
+
+ifeq (Darwin,$(OS_ARCH))
+OTR_LIBS := libotr.dylib
+endif
+
+ifeq (Linux,$(OS_ARCH))
+OTR_LIBS := libotr.so
+endif
+
+OTR_LIB_PATHS := $(foreach otrlib,$(OTR_LIBS),$(TB_LIBOTR_PREBUILT)/$(otrlib))
+
+libs:: $(OTR_LIB_PATHS)
+ $(NSINSTALL) -t -m 755 $(OTR_LIB_PATHS) $(DIST)/bin
+
+endif ## TB_LIBOTR_PREBUILT