summaryrefslogtreecommitdiffstats
path: root/comm/third_party/libotr/tests/regression/client/Makefile.am
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 17:32:43 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 17:32:43 +0000
commit6bf0a5cb5034a7e684dcc3500e841785237ce2dd (patch)
treea68f146d7fa01f0134297619fbe7e33db084e0aa /comm/third_party/libotr/tests/regression/client/Makefile.am
parentInitial commit. (diff)
downloadthunderbird-6bf0a5cb5034a7e684dcc3500e841785237ce2dd.tar.xz
thunderbird-6bf0a5cb5034a7e684dcc3500e841785237ce2dd.zip
Adding upstream version 1:115.7.0.upstream/1%115.7.0upstream
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'comm/third_party/libotr/tests/regression/client/Makefile.am')
-rw-r--r--comm/third_party/libotr/tests/regression/client/Makefile.am16
1 files changed, 16 insertions, 0 deletions
diff --git a/comm/third_party/libotr/tests/regression/client/Makefile.am b/comm/third_party/libotr/tests/regression/client/Makefile.am
new file mode 100644
index 0000000000..d2b11be132
--- /dev/null
+++ b/comm/third_party/libotr/tests/regression/client/Makefile.am
@@ -0,0 +1,16 @@
+AM_CFLAGS = -I$(top_srcdir)/include \
+ -I$(top_srcdir)/src \
+ -I$(top_srcdir)/tests/utils/ \
+ -I$(srcdir) \
+ @LIBGCRYPT_CFLAGS@
+
+LIBTAP=$(top_builddir)/tests/utils/tap/libtap.la
+
+LIBOTR=$(top_builddir)/src/libotr.la
+
+noinst_PROGRAMS = client
+
+client_SOURCES = client.c
+client_LDADD = $(LIBTAP) $(LIBOTR) -lpthread @LIBGCRYPT_LIBS@
+
+EXTRA_DIST = otr.key