summaryrefslogtreecommitdiffstats
path: root/dom/webidl/ElementInternals.webidl
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 17:32:43 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 17:32:43 +0000
commit6bf0a5cb5034a7e684dcc3500e841785237ce2dd (patch)
treea68f146d7fa01f0134297619fbe7e33db084e0aa /dom/webidl/ElementInternals.webidl
parentInitial commit. (diff)
downloadthunderbird-6bf0a5cb5034a7e684dcc3500e841785237ce2dd.tar.xz
thunderbird-6bf0a5cb5034a7e684dcc3500e841785237ce2dd.zip
Adding upstream version 1:115.7.0.upstream/1%115.7.0upstream
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to '')
-rw-r--r--dom/webidl/ElementInternals.webidl61
1 files changed, 61 insertions, 0 deletions
diff --git a/dom/webidl/ElementInternals.webidl b/dom/webidl/ElementInternals.webidl
new file mode 100644
index 0000000000..fdf4045e80
--- /dev/null
+++ b/dom/webidl/ElementInternals.webidl
@@ -0,0 +1,61 @@
+/* -*- Mode: IDL; tab-width: 2; indent-tabs-mode: nil; c-basic-offset: 2 -*- */
+/* This Source Code Form is subject to the terms of the Mozilla Public
+ * License, v. 2.0. If a copy of the MPL was not distributed with this
+ * file, You can obtain one at http://mozilla.org/MPL/2.0/.
+ *
+ * The origin of this IDL file is
+ * https://html.spec.whatwg.org/#elementinternals
+ */
+
+[Exposed=Window]
+interface ElementInternals {
+ // Shadow root access
+ readonly attribute ShadowRoot? shadowRoot;
+
+ // Form-associated custom elements
+ [Throws]
+ undefined setFormValue((File or USVString or FormData)? value,
+ optional (File or USVString or FormData)? state);
+
+ [Throws]
+ readonly attribute HTMLFormElement? form;
+
+ [Throws]
+ undefined setValidity(optional ValidityStateFlags flags = {},
+ optional DOMString message,
+ optional HTMLElement anchor);
+ [Throws]
+ readonly attribute boolean willValidate;
+ [Throws]
+ readonly attribute ValidityState validity;
+ [Throws]
+ readonly attribute DOMString validationMessage;
+ [Throws]
+ boolean checkValidity();
+ [Throws]
+ boolean reportValidity();
+
+ [Throws]
+ readonly attribute NodeList labels;
+};
+
+partial interface ElementInternals {
+ [ChromeOnly, Throws]
+ readonly attribute HTMLElement? validationAnchor;
+};
+
+ElementInternals includes AccessibilityRole;
+ElementInternals includes AriaAttributes;
+
+dictionary ValidityStateFlags {
+ boolean valueMissing = false;
+ boolean typeMismatch = false;
+ boolean patternMismatch = false;
+ boolean tooLong = false;
+ boolean tooShort = false;
+ boolean rangeUnderflow = false;
+ boolean rangeOverflow = false;
+ boolean stepMismatch = false;
+ boolean badInput = false;
+ boolean customError = false;
+};