summaryrefslogtreecommitdiffstats
path: root/testing/mochitest/mochitest-e10s-utils.js
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 17:32:43 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 17:32:43 +0000
commit6bf0a5cb5034a7e684dcc3500e841785237ce2dd (patch)
treea68f146d7fa01f0134297619fbe7e33db084e0aa /testing/mochitest/mochitest-e10s-utils.js
parentInitial commit. (diff)
downloadthunderbird-6bf0a5cb5034a7e684dcc3500e841785237ce2dd.tar.xz
thunderbird-6bf0a5cb5034a7e684dcc3500e841785237ce2dd.zip
Adding upstream version 1:115.7.0.upstream/1%115.7.0upstream
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to '')
-rw-r--r--testing/mochitest/mochitest-e10s-utils.js18
1 files changed, 18 insertions, 0 deletions
diff --git a/testing/mochitest/mochitest-e10s-utils.js b/testing/mochitest/mochitest-e10s-utils.js
new file mode 100644
index 0000000000..09046794bb
--- /dev/null
+++ b/testing/mochitest/mochitest-e10s-utils.js
@@ -0,0 +1,18 @@
+// Utilities for running tests in an e10s environment.
+
+function e10s_init() {
+ // Listen for an 'oop-browser-crashed' event and log it so people analysing
+ // test logs have a clue about what is going on.
+ window.addEventListener(
+ "oop-browser-crashed",
+ event => {
+ let uri = event.target.currentURI;
+ console.error(
+ "remote browser crashed while on " +
+ (uri ? uri.spec : "<unknown>") +
+ "\n"
+ );
+ },
+ true
+ );
+}