summaryrefslogtreecommitdiffstats
path: root/testing/web-platform/tests/console/console-label-conversion.any.js
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 17:32:43 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 17:32:43 +0000
commit6bf0a5cb5034a7e684dcc3500e841785237ce2dd (patch)
treea68f146d7fa01f0134297619fbe7e33db084e0aa /testing/web-platform/tests/console/console-label-conversion.any.js
parentInitial commit. (diff)
downloadthunderbird-6bf0a5cb5034a7e684dcc3500e841785237ce2dd.tar.xz
thunderbird-6bf0a5cb5034a7e684dcc3500e841785237ce2dd.zip
Adding upstream version 1:115.7.0.upstream/1%115.7.0upstream
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'testing/web-platform/tests/console/console-label-conversion.any.js')
-rw-r--r--testing/web-platform/tests/console/console-label-conversion.any.js29
1 files changed, 29 insertions, 0 deletions
diff --git a/testing/web-platform/tests/console/console-label-conversion.any.js b/testing/web-platform/tests/console/console-label-conversion.any.js
new file mode 100644
index 0000000000..4d48df3b1d
--- /dev/null
+++ b/testing/web-platform/tests/console/console-label-conversion.any.js
@@ -0,0 +1,29 @@
+"use strict";
+// https://console.spec.whatwg/org/#counting
+// https://console.spec.whatwg/org/#timing
+
+const methods = ['count', 'countReset', 'time', 'timeLog', 'timeEnd'];
+
+for (const method of methods) {
+ test(() => {
+ let labelToStringCalled = false;
+
+ console[method]({
+ toString() {
+ labelToStringCalled = true;
+ }
+ });
+
+ assert_true(labelToStringCalled, `${method}() must call toString() on label when label is an object`);
+ }, `console.${method}()'s label gets converted to string via label.toString() when label is an object`);
+
+ test(() => {
+ assert_throws_js(Error, () => {
+ console[method]({
+ toString() {
+ throw new Error('conversion error');
+ }
+ });
+ }, `${method} must re-throw any exceptions thrown by label.toString() conversion`);
+ }, `console.${method}() throws exceptions generated by erroneous label.toString() conversion`);
+}