summaryrefslogtreecommitdiffstats
path: root/third_party/rust/enumset/Cargo.toml
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 17:32:43 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 17:32:43 +0000
commit6bf0a5cb5034a7e684dcc3500e841785237ce2dd (patch)
treea68f146d7fa01f0134297619fbe7e33db084e0aa /third_party/rust/enumset/Cargo.toml
parentInitial commit. (diff)
downloadthunderbird-6bf0a5cb5034a7e684dcc3500e841785237ce2dd.tar.xz
thunderbird-6bf0a5cb5034a7e684dcc3500e841785237ce2dd.zip
Adding upstream version 1:115.7.0.upstream/1%115.7.0upstream
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'third_party/rust/enumset/Cargo.toml')
-rw-r--r--third_party/rust/enumset/Cargo.toml69
1 files changed, 69 insertions, 0 deletions
diff --git a/third_party/rust/enumset/Cargo.toml b/third_party/rust/enumset/Cargo.toml
new file mode 100644
index 0000000000..fea0f27b11
--- /dev/null
+++ b/third_party/rust/enumset/Cargo.toml
@@ -0,0 +1,69 @@
+# THIS FILE IS AUTOMATICALLY GENERATED BY CARGO
+#
+# When uploading crates to the registry Cargo will automatically
+# "normalize" Cargo.toml files for maximal compatibility
+# with all versions of Cargo and also rewrite `path` dependencies
+# to registry (e.g., crates.io) dependencies.
+#
+# If you are reading this file be aware that the original Cargo.toml
+# will likely look very different (and much more reasonable).
+# See Cargo.toml.orig for the original contents.
+
+[package]
+edition = "2018"
+name = "enumset"
+version = "1.0.12"
+authors = ["Alissa Rao <lymia@lymiahugs.com>"]
+description = "A library for creating compact sets of enums."
+documentation = "https://docs.rs/enumset/"
+readme = "README.md"
+keywords = [
+ "enum",
+ "bitset",
+]
+categories = ["data-structures"]
+license = "MIT/Apache-2.0"
+repository = "https://github.com/Lymia/enumset"
+
+[dependencies.enumset_derive]
+version = "0.6.1"
+
+[dependencies.serde2]
+version = "1"
+optional = true
+default-features = false
+package = "serde"
+
+[dev-dependencies.bincode]
+version = "1"
+features = ["i128"]
+
+[dev-dependencies.rustversion]
+version = "1"
+
+[dev-dependencies.serde_derive]
+version = "1"
+
+[dev-dependencies.serde_json]
+version = "1"
+
+[dev-dependencies.trybuild]
+version = "1"
+
+[features]
+alloc = []
+serde = [
+ "serde2",
+ "enumset_derive/serde",
+]
+std = [
+ "alloc",
+ "enumset_derive/proc-macro-crate",
+]
+
+[badges.maintenance]
+status = "actively-developed"
+
+[badges.travis-ci]
+branch = "master"
+repository = "Lymia/enumset"