summaryrefslogtreecommitdiffstats
path: root/third_party/rust/fluent-fallback/Cargo.toml
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 17:32:43 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 17:32:43 +0000
commit6bf0a5cb5034a7e684dcc3500e841785237ce2dd (patch)
treea68f146d7fa01f0134297619fbe7e33db084e0aa /third_party/rust/fluent-fallback/Cargo.toml
parentInitial commit. (diff)
downloadthunderbird-6bf0a5cb5034a7e684dcc3500e841785237ce2dd.tar.xz
thunderbird-6bf0a5cb5034a7e684dcc3500e841785237ce2dd.zip
Adding upstream version 1:115.7.0.upstream/1%115.7.0upstream
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'third_party/rust/fluent-fallback/Cargo.toml')
-rw-r--r--third_party/rust/fluent-fallback/Cargo.toml74
1 files changed, 74 insertions, 0 deletions
diff --git a/third_party/rust/fluent-fallback/Cargo.toml b/third_party/rust/fluent-fallback/Cargo.toml
new file mode 100644
index 0000000000..105de93998
--- /dev/null
+++ b/third_party/rust/fluent-fallback/Cargo.toml
@@ -0,0 +1,74 @@
+# THIS FILE IS AUTOMATICALLY GENERATED BY CARGO
+#
+# When uploading crates to the registry Cargo will automatically
+# "normalize" Cargo.toml files for maximal compatibility
+# with all versions of Cargo and also rewrite `path` dependencies
+# to registry (e.g., crates.io) dependencies.
+#
+# If you are reading this file be aware that the original Cargo.toml
+# will likely look very different (and much more reasonable).
+# See Cargo.toml.orig for the original contents.
+
+[package]
+edition = "2021"
+name = "fluent-fallback"
+version = "0.7.0"
+authors = [
+ "Zibi Braniecki <gandalf@mozilla.com>",
+ "Staś Małolepszy <stas@mozilla.com>",
+]
+description = """
+High-level abstraction model for managing localization resources
+and runtime localization lifecycle.
+"""
+homepage = "http://www.projectfluent.org"
+readme = "README.md"
+keywords = [
+ "localization",
+ "l10n",
+ "i18n",
+ "intl",
+ "internationalization",
+]
+categories = [
+ "localization",
+ "internationalization",
+]
+license = "Apache-2.0/MIT"
+repository = "https://github.com/projectfluent/fluent-rs"
+resolver = "1"
+
+[dependencies.async-trait]
+version = "0.1"
+
+[dependencies.chunky-vec]
+version = "0.1"
+
+[dependencies.fluent-bundle]
+version = "0.15.2"
+
+[dependencies.futures]
+version = "0.3"
+
+[dependencies.once_cell]
+version = "1.9"
+
+[dependencies.rustc-hash]
+version = "1"
+
+[dependencies.unic-langid]
+version = "0.9"
+
+[dev-dependencies.fluent-langneg]
+version = "0.13"
+
+[dev-dependencies.tokio]
+version = "1.0"
+features = [
+ "rt-multi-thread",
+ "macros",
+]
+
+[dev-dependencies.unic-langid]
+version = "0.9"
+features = ["macros"]