summaryrefslogtreecommitdiffstats
path: root/third_party/rust/memalloc/README.md
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 17:32:43 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 17:32:43 +0000
commit6bf0a5cb5034a7e684dcc3500e841785237ce2dd (patch)
treea68f146d7fa01f0134297619fbe7e33db084e0aa /third_party/rust/memalloc/README.md
parentInitial commit. (diff)
downloadthunderbird-6bf0a5cb5034a7e684dcc3500e841785237ce2dd.tar.xz
thunderbird-6bf0a5cb5034a7e684dcc3500e841785237ce2dd.zip
Adding upstream version 1:115.7.0.upstream/1%115.7.0upstream
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'third_party/rust/memalloc/README.md')
-rw-r--r--third_party/rust/memalloc/README.md26
1 files changed, 26 insertions, 0 deletions
diff --git a/third_party/rust/memalloc/README.md b/third_party/rust/memalloc/README.md
new file mode 100644
index 0000000000..d2d0489009
--- /dev/null
+++ b/third_party/rust/memalloc/README.md
@@ -0,0 +1,26 @@
+# memalloc
+
+> Raw allocation APIs in stable rust.
+
+## [Documentation](https://crates.fyi/crates/memalloc/0.1.0)
+
+## Usage
+
+See the tests at the bottom of `src/lib.rs` for some examples.
+
+Use the crates.io repository; add this to your `Cargo.toml` along
+with the rest of your dependencies:
+
+```toml
+[dependencies]
+memalloc = "0.1"
+```
+
+## Author
+
+[Jonathan Reem](https://medium.com/@jreem) is the primary author and maintainer of memalloc.
+
+## License
+
+MIT
+