summaryrefslogtreecommitdiffstats
path: root/tools/lint/ruff.yml
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 17:32:43 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 17:32:43 +0000
commit6bf0a5cb5034a7e684dcc3500e841785237ce2dd (patch)
treea68f146d7fa01f0134297619fbe7e33db084e0aa /tools/lint/ruff.yml
parentInitial commit. (diff)
downloadthunderbird-6bf0a5cb5034a7e684dcc3500e841785237ce2dd.tar.xz
thunderbird-6bf0a5cb5034a7e684dcc3500e841785237ce2dd.zip
Adding upstream version 1:115.7.0.upstream/1%115.7.0upstream
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'tools/lint/ruff.yml')
-rw-r--r--tools/lint/ruff.yml17
1 files changed, 17 insertions, 0 deletions
diff --git a/tools/lint/ruff.yml b/tools/lint/ruff.yml
new file mode 100644
index 0000000000..59ae2a1350
--- /dev/null
+++ b/tools/lint/ruff.yml
@@ -0,0 +1,17 @@
+---
+ruff:
+ description: An extremely fast Python linter, written in Rust
+ # Excludes should be added to topsrcdir/pyproject.toml
+ exclude: []
+ # The configure option is used by the build system
+ extensions: ["configure", "py"]
+ support-files:
+ - "**/.ruff.toml"
+ - "**/ruff.toml"
+ - "**/pyproject.toml"
+ - "tools/lint/python/ruff.py"
+ # Rules that should result in warnings rather than errors.
+ warning-rules: [PLR, PLW]
+ type: external
+ payload: python.ruff:lint
+ setup: python.ruff:setup