summaryrefslogtreecommitdiffstats
path: root/build/rust/nix/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'build/rust/nix/Cargo.toml')
-rw-r--r--build/rust/nix/Cargo.toml30
1 files changed, 30 insertions, 0 deletions
diff --git a/build/rust/nix/Cargo.toml b/build/rust/nix/Cargo.toml
new file mode 100644
index 0000000000..3881d7c020
--- /dev/null
+++ b/build/rust/nix/Cargo.toml
@@ -0,0 +1,30 @@
+[package]
+name = "nix"
+version = "0.24.99"
+edition = "2018"
+license = "MPL-2.0"
+
+[lib]
+path = "lib.rs"
+
+[dependencies.nix]
+version = "0.26"
+default-features = false
+
+[features]
+acct = ["nix/acct"]
+aio = ["nix/aio"]
+default = ["nix/default"]
+dir = ["nix/dir"]
+env = ["nix/env"]
+event = ["nix/event"]
+feature = ["nix/feature"]
+fs = ["nix/fs"]
+hostname = ["nix/hostname"]
+inotify = ["nix/inotify"]
+ioctl = ["nix/ioctl"]
+kmod = ["nix/kmod"]
+mman = ["nix/mman"]
+mount = ["nix/mount"]
+mqueue = ["nix/mqueue"]
+net = ["nix/net"]