summaryrefslogtreecommitdiffstats
path: root/comm/suite/Makefile.in
diff options
context:
space:
mode:
Diffstat (limited to 'comm/suite/Makefile.in')
-rw-r--r--comm/suite/Makefile.in25
1 files changed, 25 insertions, 0 deletions
diff --git a/comm/suite/Makefile.in b/comm/suite/Makefile.in
new file mode 100644
index 0000000000..634037b6ec
--- /dev/null
+++ b/comm/suite/Makefile.in
@@ -0,0 +1,25 @@
+#
+# This Source Code Form is subject to the terms of the Mozilla Public
+# License, v. 2.0. If a copy of the MPL was not distributed with this
+# file, You can obtain one at http://mozilla.org/MPL/2.0/.
+
+include $(topsrcdir)/config/rules.mk
+
+ifdef MAKENSISU
+# For Windows build the uninstaller during the application build since the
+# uninstaller is included with the application for mar file generation.
+libs::
+ $(MAKE) -C installer/windows uninstaller
+endif
+
+
+# As a fallout from bug 1247162, the sourcestamp in application.ini and
+# platform.ini are the same, which isn't a problem for Firefox, but
+# it's not right for anything else. So we correct platform.ini here.
+
+MOZ_REV=$(shell hg -R "$(topsrcdir)" parent --template="{node}" 2>/dev/null)
+
+libs:: $(DIST)/bin/platform.ini
+ sed -e "s/^\(SourceStamp=\).*/\1$(MOZ_REV)/" $(DIST)/bin/platform.ini \
+ > $(DIST)/bin/platform.ini~
+ mv -f $(DIST)/bin/platform.ini~ $(DIST)/bin/platform.ini